Ocena wątku:
  • 0 głosów - średnia: 0
  • 1
  • 2
  • 3
  • 4
  • 5
TinyESP locked
#1
Hello all,
I bought this divice for a god price in Romania.
I immediately connected it to my home wireless network and could log in webUI of EasyESP. The next step was to configure the display and after doing that I clicked on the submit button but never finished the submit process so I had to disconnect it from USB-power. Now it seems the device is bricked or it is locked. It does not connect to my wifi, I cant find it on the network. Is there anything I can do without reflashing the firmware. Right now I do not have an USB serial interface to try to flash it. Until I buy one can I do something to regain access to the device?
Thanks
Odpowiedz
#2
I tried to flash it with my new USB-to-TTL adaptor but don't know how to put it in flash mode.
Nobody can help? I thought this is the form of the producer of this thing where I will find support Smile
Odpowiedz
#3
Just an quick update.
I managed to flash it, connect it to my network but ass soon as I try to set up the OLED display when I hit submit it's not responding any more. At this point it's not accessible any more in browser but it is responding to ping on it's IP address. I had to reflash it again but same thing happened when I tried to set up the OLED display again. I even tied an 2 A power source but still the same.

Edit:
I also tried to flash first blank.bin 4MB and then EasyESP but still the same
Odpowiedz
#4
Just another update
Everything is working now. The problem was that after reflashing the default GPIO settings for the I2C on which the display is attached were not correct. It probably tied to communicate with the display on the wrong GPIO and it hanged. So after selecting the correct GPIO for I2C respectively GPIO2 and GPIO14 everything works fine. Now I try to find out how I could controle it from my mobile phone over mqtt.
Odpowiedz


Skocz do:


Użytkownicy przeglądający ten wątek: 1 gości