Ocena wątku:
  • 0 głosów - średnia: 0
  • 1
  • 2
  • 3
  • 4
  • 5
Podłączenie czujników DS18B20 do LK3
#1
Jak prawidłowo podłączyć DS18B20 do LK3?

Zgodnie z opisem 1-wire w instrukcji "lk3_short_manual" DS18B20 myślę, że należy podłączyć do pinów:
4 - 1wire (DQ czujnika)
5 - GND (GND czujnika)
6 - +3,3V (Vcc czujnika).

Moje wątpliwości budzi fakt, że kupiony czujnik DS18B20 z kablem i wtyczką RJ11 (http://www.wirelesslan.pl/product_info.p...ts_id/2585) trafia w piny 2-5 złącza 1wire LK3.
1. Czy dobrze rozumiem, że czujnik jest wtedy podłączony w układzie 2 żyłowym?
2. Czy Vcc oraz GND jest zwarte przy czujniku?
3. Czy (przy założeniu, że dobrze rozumuję powyżej) podłączenie czujnika DS18B20 w układzie 3 żyłowym może mieć wpływ na polepszenie jakości zbieranych z czujnika danych (możliwość stosowania dłuższych odcinków przewodu)?
4. Czy SPLITER RJ12 1Wire/i2c/ DS18B20 DO LK2 / LK3 podaje napięcie 3,3V na pin 6 wszystkich gniazd, czy jedynie gniazd oznaczonych kolorem białym? (http://www.wirelesslan.pl/product_info.p...ts_id/3796)

Pozdrawiam
Hubert
<t>pozdrawiam<br/>
hubert (LK v3)</t>
Odpowiedz
#2
Po dzisiejszych testach:
Ad. 4. SPLITER RJ12 1Wire/i2c/ DS18B20 DO LK2 / LK3 dzieli sygnał z 6 pinów jedynie na gniazda oznaczone kolorem białym oraz naprzeciwległe (łącznie 4 gniazda). Do pozostałych trafia sygnał jedynie z 2 pinów (4 oraz 5).
Pozdrawiam
H
<t>pozdrawiam<br/>
hubert (LK v3)</t>
Odpowiedz
#3
A nie jest to wina wykonania splitera?
Mierzyłem przejścia na spliterze i raz były a raz nie. Luty na płytce wyglądały niezbyt dobrze.
Jeszcze nie miałem czasu aby to poprawić.
Jak to wygląda u innych osób?
<t>LK v3<br/>
SW: 1.27b</t>
Odpowiedz
#4
Po kolejnych analizach:

Czujnik DS18B20 z kablem i wtyczką RJ11 (http://www.wirelesslan.pl/product_info. ... ts_id/2585) jest podłączony do następujących pinów:
2 (żółty) - +5V (Vcc czujnika)
3 (zielony) - wolny
4 (czerwony) - 1wire (DQ czujnika)
5 (czarny) - GND (GND czujnika)

Testowałem podłączenie czujnika do LK3 wykorzystując do tego: czujnik >> sieć strukturalna (ok. 20-25 m długości przewodu) >> gniazdo splitera nie oznaczone kolorem białym >> LK3. Przypuszczam, że DS pracuje wtedy w układzie 2-żyłowym. Niestety występuje ok. 60%-70% utrata wyników.
Podłączenie czujnika do gniazda splitera oznaczonego kolorem białym (DS w układzie 3-żyłowym) powoduje niestabilne zachowanie LK3 (ping odpowiada, brak informacji o temp. w polach w zakładce status, czasami można się zalogować, czasami nie, brak przesyłania informacji przez HTTP Client ...).

Czy ma ktoś wiedzę, czy w LK3 znajduje się rezystor podciągający i czy można go jakoś pominąć? Chciałbym zmierzyć prąd pomiędzy zaciskami DQ i GND przy czujniku, żeby dobrać odpowiednią wartość rezystora przy uwzględnieniu rezystancji przewodu i połączeń.
<t>pozdrawiam<br/>
hubert (LK v3)</t>
Odpowiedz
#5
hubik napisał(a):Po kolejnych analizach:
Czy ma ktoś wiedzę, czy w LK3 znajduje się rezystor podciągający i czy można go jakoś pominąć? Chciałbym zmierzyć prąd pomiędzy zaciskami DQ i GND przy czujniku, żeby dobrać odpowiednią wartość rezystora przy uwzględnieniu rezystancji przewodu i połączeń.

Tak, jest rezystor 2k2 podciagniety do 5V, mozesz go wylutować, załaczam screna gdzie sie znajduje, ten podswietlony na jasnoniebiesko.
Co do problemów LK3 z DSami to bedzie to sprawdzane bo faktycznie sa jakieś nieprawidłowości

.png   lk3-1-wire_rezystor.png (Rozmiar: 73.52 KB / Pobrań: 2,791)
pozdrawiam
tomek
Odpowiedz
#6
Dzięki. W wolnej chwili poeksperymentuję.
ps. Skonfigurowałem zestaw do mierzenia temperatury analogiczny do tego co na LK3 (połączenie pomiędzy kontrolerem, a czujnikami po sieci strukturalnej), lecz bazując na Arduino. Rezystory podciągające do 5V bezpośrednio przy DS-ach. Efekt - 100% pomiarów poprawnych. Smile
<t>pozdrawiam<br/>
hubert (LK v3)</t>
Odpowiedz
#7
w tym http://tinycontrol.pl/forum/viewtopic.php?f=28&t=6024 sofcie 1.30b, zmieniono trochę komunikacje po 1-wire z DSami, proszę potestować.
pozdrawiam
tomek
Odpowiedz
#8
Moje obserwacje po wgraniu softu 1.30b

Generalna uwaga - istotnej poprawy z DSami po 1-wire nie ma.

LK3 raczej stabilnie pracuje w następującej konfiguracji:
- czujnik wilgotności i temperatury AM2320 ("białe" gniazdo splitera),
- 3 x czujnik temperatury DS18b20 ("czarne" gniazda splitera).
W takim układzie dla DS-ów podłączonych kablem o długości > sieć strukturalna (ok. 20-25 m długości przewodu) >> gniazdo splitera "białe" >> LK3 powoduje niestabilne zachowanie LK3 (nawet gdy DS jest jedynym podłączonym do LK3 czujnikiem).
<t>pozdrawiam<br/>
hubert (LK v3)</t>
Odpowiedz
#9
po wekendzie będe testował ten spliter, rozumiem że takiego Pan używa
http://www.wirelesslan.pl/product_info.p...edluzaczem
pozdrawiam
tomek
Odpowiedz
#10
Tak, to ten
<t>pozdrawiam<br/>
hubert (LK v3)</t>
Odpowiedz


Skocz do:


Użytkownicy przeglądający ten wątek: 1 gości