Ocena wątku:
  • 0 głosów - średnia: 0
  • 1
  • 2
  • 3
  • 4
  • 5
problem ze softem SW Version:2.2 Build Date:May 9 2013
#11
+1 do tej propozycji. U kilku naszych klientów również był zwis po burzach (zapewne kwestia spadków napięcia), a i u nas w sieci zdarzyło się "zawisnąć" switchowi kilka razy. Co więcej wiesza się sam interfejs WWW, a sam switching pakietów działa bezproblemowo.

Zauważyliśmy również dziwne objawy switcha pod obciążeniem. Przy obciążeniu go około 10k pps niemalże zamiera komunikacja serwera WWW i pingi rosną do wartości dwu lub trzycyfrowych (niestety nie pamiętam czy do serwera WWW czy wszystkich urządzeń podpiętych do switcha). Spróbujcie odtworzyć taką sytuację u siebie i przetestujcie to.

Kolejna sprawa to kontrola jakości przy produkcji. Czy każdy switch jest testowany zanim zostanie zapakowany w pudełko? Trafiły nam się trzy lub cztery sztuki, które out of the box miały uszkodzony LAN1, który linkuje się na 10 Mbps w half-duplexie. Nie odsyłaliśmy ich na serwis do was, bo użyliśmy innych portów, a trzeba było pilnie zamontować je przy punktach bazowych.

Wymienione powyżej rzeczy są z kategorii "palących". Jeśli nie zostaną poprawione, to zapadła decyzja o przerzuceniu się na 5 portowe toughswitche (gdzie VLANy działają poprawnie). Funkcjonalność może i mniejsza, ale za to stabilność większa, a każdy dojazd technika celem podniesienia zawieszonego switcha ATS to strata jego czasu (może wówczas instalować lub serwisować abonenta) oraz paliwa. Jedna taka wizyta i opłaca nam się już kupić ToughSWITCHa.
<t>Rafał Wójcik<br/>
AWB-NET</t>
Odpowiedz
#12
Cytat:+1 do tej propozycji. U kilku naszych klientów również był zwis po burzach (zapewne kwestia spadków napięcia), a i u nas w sieci zdarzyło się "zawisnąć" switchowi kilka razy. Co więcej wiesza się sam interfejs WWW, a sam switching pakietów działa bezproblemowo.
Co oznacza że wisi procesor, ktory jest bardziej wrażliwy na zakłócenia. Może coś da zmina w wewnetrznym watchdogu procesora, ale pingowanie samego siebie jest tu bez sensu - nie pomoże.
Cytat:Zauważyliśmy również dziwne objawy switcha pod obciążeniem. Przy obciążeniu go około 10k pps niemalże zamiera komunikacja serwera WWW i pingi rosną do wartości dwu lub trzycyfrowych (niestety nie pamiętam czy do serwera WWW czy wszystkich urządzeń podpiętych do switcha). Spróbujcie odtworzyć taką sytuację u siebie i przetestujcie to.
Testy wydajnościowe były robione, ale nie pamiętam czy z taką ilością pakietów i czy faktycznie sprawdzaliśmy www czy tylko szybkość (albo raczej opóźnienie) przełącznika. Sprawdzimy to jeszcze ponownie. Sam switch to sprawdzony układ Realteka, który raczej wyrabia w typowych zastosowaniach WISP.
Cytat:Kolejna sprawa to kontrola jakości przy produkcji. Czy każdy switch jest testowany zanim zostanie zapakowany w pudełko? Trafiły nam się trzy lub cztery sztuki, które out of the box miały uszkodzony LAN1, który linkuje się na 10 Mbps w half-duplexie. Nie odsyłaliśmy ich na serwis do was, bo użyliśmy innych portów, a trzeba było pilnie zamontować je przy punktach bazowych.
Oczywiście testujemy wszystkie, także sprawdzamy zasilanie PoE. Być może problem jest z zimnym lutem, była partia ukladow która lutowała sie bardzo wrednie. To może powodować spadek pasma i pracę tylko na 10Mb. Takie rzeczy niestety ciężko wykryć w czasie włączania switcha na biurku. Oczywiście wymienimy w dogodny sposób, proszę o kontakt w firmie z handlowcami lub serwisem.
Co do samego zawieszania się to mam pytanie: switch pracuje z zasilacza buforowego? Inne urzadzenia w tym punkcie też sie wykładaja, czy tylko switch?
<t></t>
Odpowiedz
#13
notek napisał(a):Testy wydajnościowe były robione, ale nie pamiętam czy z taką ilością pakietów i czy faktycznie sprawdzaliśmy www czy tylko szybkość (albo raczej opóźnienie) przełącznika. Sprawdzimy to jeszcze ponownie. Sam switch to sprawdzony układ Realteka, który raczej wyrabia w typowych zastosowaniach WISP.
Nie wyrabia się sam układ od interfejsu WWW. Nie pamiętam czy to jakiś Atmel czy Pic lub coś innego. Pytanie, czy to nie wyrabia się on, czy też przy zbyt dużej ilości ppsów Realtek po prostu zdycha. Do sprawdzenia.


notek napisał(a):Oczywiście testujemy wszystkie, także sprawdzamy zasilanie PoE. Być może problem jest z zimnym lutem, była partia ukladow która lutowała sie bardzo wrednie. To może powodować spadek pasma i pracę tylko na 10Mb. Takie rzeczy niestety ciężko wykryć w czasie włączania switcha na biurku. Oczywiście wymienimy w dogodny sposób, proszę o kontakt w firmie z handlowcami lub serwisem.
Tak jak wspomniałem, są gdzieś produkcyjnie zainstalowane i po prostu inne portu użyliśmy.


notek napisał(a):Co do samego zawieszania się to mam pytanie: switch pracuje z zasilacza buforowego? Inne urzadzenia w tym punkcie też sie wykładaja, czy tylko switch?
Pracuje z bufora 24V na pewno (czyli na wyjściu jest pewnie 27.6V lub coś w tej okolicy). Bufor zasila switch, a dalej za nim wszystkie urządzenia są już zasilane ze switcha. Tak jak napisałem – switch działa cały czas prawidłowo jako sam switch. Po pewnym czasie, na niektórych sztukach przestaje działać sam interfejs WWW (czyli podejrzewam drugi scalak Atmel czy co tam jest) lub bug w sofcie? Nie wiem czy w tak małych wsadach do tych scalaków da się zrobić memory leaka przykładowo? Pewnie się da. Zamiera samo WWW i switch przestaje się pingować pod adresem wskazanym w konfiguracji. Tak to wygląda. Nie każda sztuka tak ma. To jest bardzo ważne. Na każdej sztuce na pewno mamy inne wersje softu.
<t>Rafał Wójcik<br/>
AWB-NET</t>
Odpowiedz
#14
Raf napisał(a):Pracuje z bufora 24V na pewno (czyli na wyjściu jest pewnie 27.6V lub coś w tej okolicy). Bufor zasila switch, a dalej za nim wszystkie urządzenia są już zasilane ze switcha. Tak jak napisałem – switch działa cały czas prawidłowo jako sam switch. Po pewnym czasie, na niektórych sztukach przestaje działać sam interfejs WWW (czyli podejrzewam drugi scalak Atmel czy co tam jest) lub bug w sofcie? Nie wiem czy w tak małych wsadach do tych scalaków da się zrobić memory leaka przykładowo? Pewnie się da. Zamiera samo WWW i switch przestaje się pingować pod adresem wskazanym w konfiguracji. Tak to wygląda. Nie każda sztuka tak ma. To jest bardzo ważne. Na każdej sztuce na pewno mamy inne wersje softu.

Jeśli uzadzenia sa zasilane po switchu, to w przypadku jak zanika komunikacja switchem to czy samo zasilanie na portach switcha dalej jest wysterowane?
Czy widzisz jakąs zaleznos miedzy wersja softu a problemami?
pozdrawiam
tomek
Odpowiedz
#15
Tak, jest wysterowane. Tak jak wspomniałem wcześniej – wszystko zostaje "po staremu". Podpięte urządzenia (najczęściej kilka Ubiquiti i jeden MikroTik) pracują nadal, komunikacja między nimi działa (zatem Realtek działa prawidłowo). Natomiast nie dasz rady pingować IP zadanego waszemu urządzeniu i nie dostaniesz się do jego ustawień WWW. Pomoże tylko reset prądowy.
Jeśli chodzi o zależność między wersjami wsadów. Ciężka sprawa… Nie jestem w stanie dać teraz odpowiedzi.
<t>Rafał Wójcik<br/>
AWB-NET</t>
Odpowiedz
#16
Prosiłbym o test, na switchu , który sie zawiesza ustawić watchdoga na wolnym wyjsciu gdzie nie jest nic podpiete na jakiś adres w necie. Jak przestanie odpowiadać na www to sprawdzić czy zgasła dioda pokazujaca zasilanie na danym porcie.
pozdrawiam
tomek
Odpowiedz
#17
Z naszej strony nie jest to wykonalne. Switche są zamontowane produkcyjnie w różnych miejscowościach, gdzie świadczymy dostęp. Nikt nie będzie czatował przy switchu i go obserwował. To ma po prostu działać. Ja mogę tylko zgłosić problem.
<t>Rafał Wójcik<br/>
AWB-NET</t>
Odpowiedz
#18
Ok, ale nie trzeba siedziec przy switchu, raczej przy okazji, jak by sie zawiesil i ktos tam był to zerknać na port z ustawionym watchdoogiem
pozdrawiam
tomek
Odpowiedz
#19
jest nowy soft, co prawda nie ma jeszce watchdoga do resetowania samego switcha ale bylo kilka poprawek wieć proszę o testy.
http://tinycontrol.pl/forum/viewtopic.php?f=8&t=5534

Do tych którym zawisnal swicth i nie odpowiadal przez www oraz na pingi. Prosil bym w takim przypadku spróbować połączyć się z swichem aplikacją do upgradu softu i dać znać czy próba sie udała
pozdrawiam
tomek
Odpowiedz
#20
witam, czy będzie w końcu jakiś postęp w pracach restartowania, watchodog-ga samego switcha ? Nie ukrywam, że jeśt to dla mnie ważna i priorytetowa sprawa. Mam w sieci ok. 50 takich switch i problem jest tylko z nimi. Wszsytkie urządzenia Ubiquiti, Miktorik mają wbudowanego watchdoga-a i gdy się jest odpowiednio skonfiguruje to działają prawidłowo. ten switch tego nie ma i jest wielki problem. Pisałem nie tylko Ja w tej sprawie do autora aby coś z tym zrobić, ale nadal nic....wachałem się przed zakupem tego sprzętu. Skusiła mnie cena - teraz wiem, że to był błąd ! Jeśli nic w tym temacie się nie zmieni to już nie zakupię tego sprzętu i w całości przerzucę się na ubiquiti.... W nowym roku 2014 mam do zrobienia 80 punktów dystrybucyjnych a co za tym idzie 80 switch-y. Może warto by było się postarać ?! Co powie na to autor ?
<t></t>
Odpowiedz


Skocz do:


Użytkownicy przeglądający ten wątek: 1 gości