Thanks
I found a script in this way
/tool fetch url="http://192.168.1.100/outs.cgi?out0=0" mode=http
or
/tool fetch url="http://192.168.1.100/outs.cgi?out0=1" mode=http
-------------------------
:local date [/system clock get date]
:local sonuc ""
:local months [:toarray "jan,feb,mar,apr,may,jun,jul,aug,sep,oct,nov,dec"]
:local monthtbl [:toarray "0,3,3,6,1,4,6,2,5,0,3,5"]
:local daytbl [:toarray "sun,mon,tue,wed,thu,fri,sat"]
:local month [:pick $date 0 3]
:local day [:pick $date 4 6]
:local dayc [:pick $date 5 6]
:local century [:pick $date 7 9]
:local year [:pick $date 9 11]
:local yearc [:pick $date 10 11]
:if ([:pick $date 4 5] = 0) do={
et day ($dayc)}
:if ([:pick $date 9 10] = 0) do=[
et year ($yearc)]
:local sum 0
et sum ($sum + (2 * (3 - ($century - (($century / 4) * 4)))))
et sum ($sum + ($year / 4))
et sum ($sum + $year + $day)
:for mindex from=0 to=[:len $months] do={
:if ([:pick $months $mindex] = $month) do={
et sum ($sum + [:pick $monthtbl $mindex]) }
}
et sum ($sum - (($sum / 7) * 7))
et sonuc [:pick $daytbl $sum]
# gun hesaplama tamam
#:put ([:pick $date 0 3] . "/" . [:pick $date 4 6] . "/" . [:pick $date 7 9] . [:pick $date 9 11] . " is on a " . $sonuc)
:put $sonuc
{
:if ($sonuc = "sat") do={
# gun dogruysa
put "deger dogru"
} else={
# gun yanlis sa
/tool fetch url="http://192.168.1.100/outs.cgi?out0=1" mode=http
put "deger yanlis"
}
}