Ocena wątku:
  • 0 głosów - średnia: 0
  • 1
  • 2
  • 3
  • 4
  • 5
LK3.5-NOWY SOFT - KOLEJNE WERSJE
SW 1.52 | HW 3.7  zmiana stanu event po htapi http://192.168.1.100/outs.cgi?vout2=1 prawdopodobnie nie działa Sad  może ktoś to jeszcze sprawdzić czy to odosobniony przypadek na moim LK
próba aktualizacji po httapi zeruje wszystkie wpisy eventów a zadania oparte na eventach mają true niezależnie od ich stanu  , zdalne sterowanie działa i zmienia jak należy stany eventów
update: użycie tej komendy httpapi powoduje prawdopodobnie też nadpisanie ustawień i2c
   
pojawia się też problem w zapisie 17 pozycji w zdarzeniach, a wybrane zadania do tej pozycji nie działają poprawnie!!!

Jak sprawdzić czy dotyka cię ww błąd - dodaj zdarzenia następnie je usuń i ponownie dodaj do 20 pozycji. Jeśli masz przeskok powyżej pozycji 16 to musisz przywrócić ustawienia fabryczne i ręcznie skonfigurować wszystko. Przywrócenie ustawień z pliku niestety w tej sytuacji nie pomoże. Problem pojawi się ponownie przy obsłudze v-eventów
   
__________________________________________________________________________________________
pytanie o 3 parametr w zdarzeniach dla uproszczenia bez OR NOR AND ect
mamy zdarzenie1 if inpd1  = 1 {out0= 1}
zdarzenie2 if inpd2  = 1 AND event in pos 1 = 1 {autoswitchout1= 1}

rozważmy 2 zdarzenie
mam wrażenie ze to działa liniowo czyli jeśli zdarzenie 1 jest true i zdarzenie 2 jest true to autoswitchout1=1 jeśli nie to autoswitchout1= 0 
a powinno działać na zasadzie jeśli zdarzenie 1 jest true to sprawdzam czy zdarzenie 2 jest true i wykonuje autoswitchout1= 1 jeśli zdarzenie 1 jest false to pomijam całkowicie zdarzenie 2 bo jet zależne właśnie od niego i nie robię nic na autoswitchout1
__________________________________________________________________________________________
modem GSM odczyt sms przy pomocy komendy AT+CMGL="ALL",1 (poprzedzony poleceniem AT+CSCS="GSM") zwraca tylko OK problem powiązany z błędem opisanym https://forum.tinycontrol.pl/showthread....34#pid9134
<t></t>
Odpowiedz
Would it be possible to program after sending this sms: “STATUS?” That lancontroller answer with sms message according to my setting parameters?

This functionality it would be make our work easier.

[Obrazek: TtpLMG8.png]
Odpowiedz
witam, zaobserwowałem taki problem:
SW 1.53 / HW 3.6
po zaniku zasilania w ustawieniach Moc i Energia w P/E6 zmienia się samoczynnie jednostka. Miałem ustawione W->kW a po zaniku i powrocie zasilania jest W.
wartość mocy podbiera się z m1  modbus,
tak samo mam ustawione P/E1 i tu po zaniku zasilania jednostka się nie zmienia.
jedyna różnica jest taka że P/E6 mam zerowane w schedulerze a P/E1 nie, chyba bez związku.
Zaobserwowałem to klika razy po zaniku zasilania, wtedy wartość mocy P1 pojawia się bardzo duża. 
Generalnie można z tym żyć ale na wykresach wychodzi ogromny wzrost :-(

czy twórcy coś popatrzą w kodzie?

dziękuję
<t></t>
Odpowiedz
(09-18-2022, 06:08 PM)krzychor napisał(a): witam, zaobserwowałem taki problem:
SW 1.53 / HW 3.6
po zaniku zasilania w ustawieniach Moc i Energia w P/E6 zmienia się samoczynnie jednostka. Miałem ustawione W->kW a po zaniku i powrocie zasilania jest W.
wartość mocy podbiera się z m1  modbus,
tak samo mam ustawione P/E1 i tu po zaniku zasilania jednostka się nie zmienia.
jedyna różnica jest taka że P/E6 mam zerowane w schedulerze a P/E1 nie, chyba bez związku.
Zaobserwowałem to klika razy po zaniku zasilania, wtedy wartość mocy P1 pojawia się bardzo duża. 
Generalnie można z tym żyć ale na wykresach wychodzi ogromny wzrost :-(

czy twórcy coś popatrzą w kodzie?

dziękuję

Poprawimy w nastepnej wersji

(09-18-2022, 02:32 PM)Petro napisał(a): Would it be possible to program after sending this sms: “STATUS?” That lancontroller answer with sms message according to my setting parameters?

This functionality it would be make our work easier.

[Obrazek: TtpLMG8.png]
We add this options in next firmware

(08-20-2022, 06:17 PM)stAch napisał(a): SW 1.52 | HW 3.7  zmiana stanu event po htapi http://192.168.1.100/outs.cgi?vout2=1 prawdopodobnie nie działa Sad  może ktoś to jeszcze sprawdzić czy to odosobniony przypadek na moim LK
próba aktualizacji po httapi zeruje wszystkie wpisy eventów a zadania oparte na eventach mają true niezależnie od ich stanu  , zdalne sterowanie działa i zmienia jak należy stany eventów
update: użycie tej komendy httpapi powoduje prawdopodobnie też nadpisanie ustawień i2c

pojawia się też problem w zapisie 17 pozycji w zdarzeniach, a wybrane zadania do tej pozycji nie działają poprawnie!!!

Jak sprawdzić czy dotyka cię ww błąd - dodaj zdarzenia następnie je usuń i ponownie dodaj do 20 pozycji. Jeśli masz przeskok powyżej pozycji 16 to musisz przywrócić ustawienia fabryczne i ręcznie skonfigurować wszystko. Przywrócenie ustawień z pliku niestety w tej sytuacji nie pomoże. Problem pojawi się ponownie przy obsłudze v-eventów

Nie zauważyłem takich problemów przy wydawaniu komendy http://192.168.1.100/outs.cgi?vout2=1

(08-20-2022, 06:17 PM)stAch napisał(a): pytanie o 3 parametr w zdarzeniach dla uproszczenia bez OR NOR AND ect
mamy zdarzenie1 if inpd1  = 1 {out0= 1}
zdarzenie2 if inpd2  = 1 AND event in pos 1 = 1 {autoswitchout1= 1}

rozważmy 2 zdarzenie
mam wrażenie ze to działa liniowo czyli jeśli zdarzenie 1 jest true i zdarzenie 2 jest true to autoswitchout1=1 jeśli nie to autoswitchout1= 0 
a powinno działać na zasadzie jeśli zdarzenie 1 jest true to sprawdzam czy zdarzenie 2 jest true i wykonuje autoswitchout1= 1 jeśli zdarzenie 1 jest false to pomijam całkowicie zdarzenie 2 bo jet zależne właśnie od niego i nie robię nic na autoswitchout1

Tutaj faktycznie, chyba dokany zmiany, żeby nie wykonywal akcji jesli warynek EV X nie jest spełnion.
Chociaz czy taka funkcjonalnośc jest napewno oczekiwana, bo załużmy przypadek, że warynek 1 jest spełniony i autoswitch sie załaczyło. Po pewnym czasie warnek pieerwszy nie jest spełniony więć warunek drugi nie jest sprawdzany, a auto switch cały czas dalej działa.
pozdrawiam
tomek
Odpowiedz
(09-19-2022, 08:46 AM)wilkxt napisał(a):
(08-20-2022, 06:17 PM)stAch napisał(a): SW 1.52 | HW 3.7  zmiana stanu event po htapi http://192.168.1.100/outs.cgi?vout2=1 prawdopodobnie nie działa Sad  może ktoś to jeszcze sprawdzić czy to odosobniony przypadek na moim LK
próba aktualizacji po httapi zeruje wszystkie wpisy eventów a zadania oparte na eventach mają true niezależnie od ich stanu  , zdalne sterowanie działa i zmienia jak należy stany eventów
update: użycie tej komendy httpapi powoduje prawdopodobnie też nadpisanie ustawień i2c

pojawia się też problem w zapisie 17 pozycji w zdarzeniach, a wybrane zadania do tej pozycji nie działają poprawnie!!!

Jak sprawdzić czy dotyka cię ww błąd - dodaj zdarzenia następnie je usuń i ponownie dodaj do 20 pozycji. Jeśli masz przeskok powyżej pozycji 16 to musisz przywrócić ustawienia fabryczne i ręcznie skonfigurować wszystko. Przywrócenie ustawień z pliku niestety w tej sytuacji nie pomoże. Problem pojawi się ponownie przy obsłudze v-eventów

Nie zauważyłem takich problemów przy wydawaniu komendy http://192.168.1.100/outs.cgi?vout2=1
u mnie nie trzyma ustawien i2c i 16

(08-20-2022, 06:17 PM)stAch napisał(a): pytanie o 3 parametr w zdarzeniach dla uproszczenia bez OR NOR AND ect
mamy zdarzenie1 if inpd1  = 1 {out0= 1}
zdarzenie2 if inpd2  = 1 AND event in pos 1 = 1 {autoswitchout1= 1}
.......

Tutaj faktycznie, chyba dokany zmiany, żeby nie wykonywal akcji jesli warynek EV X nie jest spełnion.
Chociaz czy taka funkcjonalnośc jest napewno oczekiwana, bo załużmy przypadek, że warynek 1 jest spełniony i autoswitch sie załaczyło. Po pewnym czasie warnek pieerwszy nie jest spełniony więć warunek  drugi nie jest sprawdzany, a auto switch cały czas dalej działa.
tak takie zamierzenie może przykład nie najlepszy ale chodzi o to by jednym parametrem a raczej jedna regułą wyłączyć /ominąć/ kilka innych zadań
<t></t>
Odpowiedz
(09-18-2022, 06:08 PM)ponownie proszę o poprawę  i przypominam o błędzie - po braku zasilania ginie ustawienie jednostek w Moc/Energia (W->kW)dziękujękrzychor napisał(a): witam, zaobserwowałem taki problem:
SW 1.53 / HW 3.6
po zaniku zasilania w ustawieniach Moc i Energia w P/E6 zmienia się samoczynnie jednostka. Miałem ustawione W->kW a po zaniku i powrocie zasilania jest W.
wartość mocy podbiera się z m1  modbus,
tak samo mam ustawione P/E1 i tu po zaniku zasilania jednostka się nie zmienia.
jedyna różnica jest taka że P/E6 mam zerowane w schedulerze a P/E1 nie, chyba bez związku.
Zaobserwowałem to klika razy po zaniku zasilania, wtedy wartość mocy P1 pojawia się bardzo duża. 
Generalnie można z tym żyć ale na wykresach wychodzi ogromny wzrost :-(

czy twórcy coś popatrzą w kodzie?

dziękuję
<t></t>
Odpowiedz
Tak, poprawimy to
pozdrawiam
tomek
Odpowiedz
Witam czy ten błąd w zdarzeniach to da się naprawić czy tylko reset do fabrycznych ??
Nic nie daje usuwanie bo wraca znów.
   
Odpowiedz
Witam.
SW 1.52 | HW 3.8 - prawdopodobnie znalazłem błąd w DIFF z użyciem wartości DEW POINT . Mam DIFF1= DEW POINT + INPA1 ,gdzie INPA1 jest zawsze równe 0 (po to ,żeby wysyłać na MQTT  DIFF1 jako wartość równą DEW POINT). Działa to poprawnie przy wartościach dodatnich natomiast przy DEW POINT < 0  DIFF zwraca jakieś olbrzymie liczby dodatnie .
np. przy T1=0,6 °C , H1= 87,1 i DEW POINT=-1,3 , DIFF1 (czyli -1,3 + 0) =6552,300  .
Odpowiedz
Hi,
I have a problem with the P/E1 input.
During the measurement of electricity production often the value is set to zero.

I have a 3 phase 500imp/kWh meter connected.

Thank you in advance for any advice.

.zip   LK3SupportFile-HW-SW-0195F4.zip (Rozmiar: 1.55 KB / Pobrań: 12)

   
Odpowiedz


Skocz do:


Użytkownicy przeglądający ten wątek: 3 gości